Removr 1.3.3 has been submitted

This is a minor bug fix release that makes it compatible with iOS 5. It remains compatible with iOS 3.1.3 or later.

Leave a Reply